ACR Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I’ve been having issues with the brass ejection pattern andjamming with my ACR. I am noticing thatthe brass is ejecting to the 1 o’clock position. Also at times the brass is hitting the frontof the ejection port causing the brass to just drop straight down or shoot offin an erratic direction. I am alsogetting stove pipe jams and also sometimes the spent round would spin aroundand face backwards and try to load back into the chamber and cause a jam. The jams occur a lot more often when I rapidfire.

When I sent my ACR off to bushmaster for the recall a fewmonths back I mentioned this issue to them and they sent back the rifle with anote that said they cleaned the extractor and extractor plunger and test fired. I took it out to the range and the problemstill exists.

I have tried different types of ammo (PMC, Winchester WhiteBox, XM193, BVAC) and all give me the same issue. I have also tried changing the extractorspring to a Bravo Company Extractor spring with and without the O-ring with nochange to the issue. I also detail stripand clean my ACR every time I comeback from the range.

I’ve always been told when brass ejects forward thatthe bolt carrier is cycling to fast. Onan AR putting a heavier buffer would help slow down the cycling. What does one do on the ACR to resolve theissue? Anyone having the same issue orknow a resolution?

Here is a pic of my ejection port. Notice all the areas where the brass ishitting the ejection port. Not normal…

 

·
Registered
Joined
·
88 Posts
i had the same issue. you need the H/L regulator. i got the H/L reg and fired 200 rounds with no issues. then i put the S/U regulator back on it and it started jammin again. ive seen pics of new acr gas regulators and it look like they secretly changed the S/U regulator to how the H/L one is made.
 
1 - 2 of 2 Posts
Top